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Using Waypoints with ProMark3 
13 June 2007 
 
Note: These instructions describe the latest versions of ProMark3 receiver firmware and 
the latest version of MobileMapper Office. You may download the latest versions at no 
charge from the following folders on ftp.magellangps.com: 

a. ProMark3 firmware:   /Land Survey/PM3/Firmware 
b. MobileMapper Office:  /Mobile Mapping/MM Office/Software 

 
How do I create waypoint files in MobileMapper Office for 
uploading to the ProMark3 receiver? 
Click Options>Select Coordinate System and either select a previously used coordinate 
system or create a new one to match the coordinate system of the waypoints you wish to 
input into MobileMapper Office. Click Tools > Place Waypoints or click the Place 
Waypoints icon (a push pin) in the main tool bar. This launches the Waypoints window 
to the right of the map screen. You may select from a variety of map symbols to identify 
the waypoints. You may also use the box under the symbols to name the waypoint that 
you wish to place on the map. Then click on the location on the map screen where you 
wish to place the first waypoint. To see more precisely where the arrow cursor is located, 
you may refer to the coordinates’ box to the lower right of the map screen. The level of 
precision here corresponds to the level of precision with which you can move the cursor. 
Once a waypoint is placed on the map screen, you can adjust its location with greater 
precision by editing its coordinates on the Waypoints window.  
Note: use only alphanumeric characters, dashes and underscores when describing a 
waypoint in the Message field. 
 
The coordinates’ box (to the lower right of the map screen) 
only displays the coordinates of the arrow cursor when I’m in 
latitude/longitude. How do I display coordinates when using a 
grid system? 
You probably have not selected the correct zone for your grid system. Click Options > 
Coordinate System and reselect the zone. If you do not know the zone, select the 
Geodetic, WGS84 option instead of the grid, position the arrow cursor in the center of 
your positions (features or waypoints) and make a note of the longitude. Then go back to 
Options > Coordinate System, reselect the grid system you want and select the zone 
based on the longitude in degrees that you just wrote down. To determine which state 
plane coordinate system zone you are in, please refer to http://www.ngs.noaa.gov/cgi-
bin/spc_zones.prl. 
 
I did not use the default name (WPT001) for the first waypoint, 
but when I add more waypoints each is automatically given the 
default name. Is there any way to automatically increment 
non-default waypoint names? 
Because you are free to use all six characters to name your waypoints, the automatic 
incrementing of the waypoint names works only for the default waypoint name where the 
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first three characters are always “WPT” and the subsequent characters are numerals 
beginning with “001.” 
Note: use only alphanumeric characters, dashes and underscores when naming a 
waypoint. 
 
How do I edit waypoint files in MobileMapper Office? 
If you want to edit the parameters for your waypoints, we recommend that you first place 
the arrow cursor on the boundary between the map window and the waypoint window. 
Click and drag this boundary to the left so as to enlarge the waypoint window to reveal 
all the parameter fields that you may edit. To edit any parameter for any waypoint, 
double-click on the field and type in a new value. These parameters include: 

- Display/hide waypoint 
- Waypoint name 
- Latitude (northing) 
- Longitude (easting) 
- Altitude 
- Icon (map symbol) 
- Message (Note: use only alphanumeric characters, dashes and underscores in the 

message field) 
You will notice that there is increased level of precision when editing a waypoint’s 
position: one one-thousandths of a minute or one tenth of a meter/foot. 
 
How do I build routes in MobileMapper Office? 
Once you have positioned some waypoints you may link them together to form routes. 
Click Tools > Build Routes or click the Build Routes icon next to the Place 
Waypoints’ push pin icon. (The Build Routes icon represents three waypoints connected 
with straight lines.)  Then use the arrow cursor to click on the waypoints in the desired 
order in which you want to build the route. 
 
How do I save my waypoint files in MobileMapper Office? 
All waypoint and route files must be associated with a MobileMapper job file (*.mmj). 
So, you first must save the waypoints to a job by clicking on File > Save As. When you 
select a job name, two files are actually created by MobileMapper Office: the job file 
(filename.mmj) and a separate waypoint file (filename.mmw). You do NOT have to 
import any features into the job file for the waypoint file to be generated. 
 
How do I import waypoint files into MobileMapper Office for 
upload to the receiver? 
In order to import a waypoint file into MobileMapper Office it must be in the same 
format as MobileMapper waypoint files or specially formatted .txt or .xls file. There is no 
conversion module to automate the importing of files in other formats.  
 
A. Importing a .xls file 
It is also possible to import waypoints contained in Microsoft Excel files if the format is 
correct. The diagram on the following page is an example of what information must be in 
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each column. Note: the first row of column headers is mandatory. Also, all entries in the 
Message field must contain only alphanumeric characters, dashes and underscores. 
 

# Name Icon Message Latitude Longitude Altitude
(m) 

Latitude 
(degrees) 

Longitude 
(degrees) 

Icon ID

1WPT001 Crossed Square   N37°21.087' W121°56.186' 0 37.35145517 -121.93643283a 
2WPT002 Crossed Square   N37°21.128' W121°56.153' 0 37.35213600 -121.93589100a 
3WPT003 Crossed Square   N37°21.090' W121°56.070' 0 37.35150367 -121.93450083a 
4WPT004 Crossed Square   N37°21.039' W121°56.093' 0 37.35065350 -121.93488717a 

     
 
An Excel spreadsheet (MM Office Waypoint Formatter.xls) can help you with the 
formatting of waypoint files in spreadsheet format.  It is located in the /Mobile 
Mapping/MM Office/Application Notes/ folder of ftp.magellangps.com.  
 
B. Importing a .txt file 
In order to import a txt waypoint file in .txt format, the file must contain the following 
information:  

1. A command line: “$PMGNWPL” 
2. A numeric field is the latitude in DDMM.MMMMM (Degrees.Minutes.Decimal 

Minutes to 5 places) 
3. An N (or S) for north (or south) latitude 
4. A second numeric field for the longitude in DDDMM.MMMMM format 

(Degrees/Minutes/Decimal Minutes to 5 places) 
5. An E (or W) for east (west) longitude 
6. A third numeric field (in the example below, a zero) for the altitude 
7. A field for the units (must be the letter “M”) 
8. A field containing the waypoint’s name, e.g., WPT001 
9. A field for a message. Note: all entries in the Message field must contain only 

alphanumeric characters, dashes and underscores. 
10. A final field containing a code for selecting a waypoint symbol: 

a. Input “a” for   
b. Input “b” for  
c. Input “t” for  
d. Input “v” for  
e. Input “x” for  

 
Example of a waypoint file in .txt format 
$PMGNWPL,3721.08731,N,12156.18597,W,0,M,WPT001,near tree,a 
$PMGNWPL,3721.12816,N,12156.15346,W,0,M,WPT002,,a 
$PMGNWPL,3721.09022,N,12156.07005,W,0,M,WPT003,,a 
$PMGNWPL,3721.03921,N,12156.09323,W,0,M,WPT004,,a 
 
After you have created the .txt or .xls file, in MobileMapper Office, click File > Import 
to open up the (mislabeled) Import GIS Data window. Select Waypoint/Routes in the 
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Files of type field.  Browse to the folder containing the file you wish to import, highlight 
it and click Open. After importing a waypoint file into MobileMapper Office, you can 
edit waypoint names, icons and messages as desired. 
 
How do I upload waypoint and/or route files into the ProMark3 
receiver? 
A. Create a job on your PC 
With the waypoints/routes displayed on MobileMapper Office’s map display area, click 
File > Save As to save the file to a folder on your PC. You may call the job whatever you 
want. This action saves both a job file (*.MMJ) and the waypoint file (*.MMW) to the 
same folder. When you upload the job to the receiver the waypoint files are automatically 
uploaded with the job. When you open the job file in the field, the receiver automatically 
displays the waypoints. 
 
B. Upload the job to the receiver 
There are two ways to upload a job to the receiver: 

1. Attach the ProMark3 I/O module to the PC with the USB cable. Then, turn on the 
receiver, launch the Mobile Mapping application and in MobileMapper Office, 
click File > Upload to GPS > Job. 

2. Or put the receiver’s SD card in a card reader and use Windows Explore to copy 
the job file (*.MMJ) and waypoint file (*.MMW) to the SD card.  Then insert the 
card into the receiver. 

 
How do I display waypoints in the ProMark3 receiver? 

1. Launch the Mobile Mapping application (you can later switch to the Surveying 
application, if you wish) 

2. If you transferred the job to the receiver’s SD card using a card reader, press 
MENU > Setup > Storage, highlight SD Card and press ENTER  

3. Press MENU > Setup > Map Setup > Display, scroll down to Waypoints and 
press ENTER to add a check mark to the box. Then press ESC to return to the 
Setup menu and ESC again to exit the Setup menu. 

4. Press LOG and open the job. 
5. Press Done at the lower right to exit the job. 
6. The waypoints will continue to be displayed.  If you close the Mobile Mapping 

application and run the Surveying application, the waypoints will continue to be 
displayed. 

 
How do I display routes in the ProMark3 receiver? 
To select a route, press the MENU button and select the Routes option. You then select 
the specific route you want to use, press enter and select the waypoint where you wish to 
begin using the route. 
 
How do I hide waypoint files in the ProMark3 receiver? 
Press MENU and select the Setup option and then the Map Setup option. Tap the 
Display tab. Scroll down to Clear All or Waypoints and press ENTER. Then press ESC 
to accept the changes and move back to the Setup screen. 
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Can I edit waypoint descriptions in the ProMark3 receiver? 
Not at this time. 
 
How do I create waypoints in the ProMark3 receiver? 
You can create waypoints when running both the Surveying and Mobile Mapping 
applications by pressing the MENU button and selecting the Mark option. However, if 
you wish to download the waypoints in a file to your PC, you open a job in the Mobile 
Mapping applications while the waypoints are displayed on the map screen and then save 
the job to memory. When you download the job file (with an .mmj file extension) using 
MobileMapper Office, the associated waypoint file will also be downloadable. 
Note: you can use only alphanumeric characters, dashes and underscores in waypoint 
names and message fields. 
 
How do I delete waypoint files from the ProMark3 receiver? 
You can do this in four ways: 

1. When downloading files using the MobileMapper Transfer Utility, click any file 
you wish to delete and click the Delete button on your keyboard or on the 
Utility’s tool bar. You can also right-click on any file and select the Delete option. 

2. With the SD card in a card reader, use Windows Explore to delete any file. 
3. Formatting an SD card will delete all the files on the card. Magellan recommends 

that you reformat your SD card before every project, or more often, if you wish. 
To do this, put the card in a card reader attached to your PC. Use Windows 
Explore to right-click to the card’s drive and select the Format option.  

 
How do I download waypoint files from the ProMark3 receiver 
to MobileMapper Office? 
1. Attach the I/O module to the receiver and connect the I/O module to the PC with the 

USB cable. 
2. Turn the receiver on and run either the Surveying or Mobile Mapping application 
3. In MobileMapper Office, click File > Download Waypoints/Routes 
You may alternatively place the receiver’s SD card in a card reader and, in 
MobileMapper Office, click File > Download Waypoints/Routes and navigate to the 
drive representing the card reader. 
 
When I downloaded the waypoint file, only some of the 
waypoints were downloaded.  How can I download the others? 
Some PCs handle downloads better when using a serial cable. Remove the USB cable 
and attach a serial cable with null modem adapter between the I/O module’s COM1 port 
the PC’s COM1 port.  Re-establish communications between MobileMapper Office and 
the ProMark3 and try the download again. 
 
How do I use MobileMapper Office to edit waypoint files 
recorded in the field? 
The process is the same as when you use MobileMapper Office to create waypoint files. 
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Can I export waypoints out of MobileMapper Office? 
Not with the present version. A workaround is to use the ProMark3’s Mobile Mapping 
program to collect point features instead of waypoints. Point features can be much more 
conveniently described using feature libraries instead of the 30-character text field that is 
available for waypoints. Also, point features can be easily exported in GIS formats using 
MobileMapper Office. 


